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CCD Explorer is a freeware program written in Visual Basic 6.0 to manage your CCD 
images.  This program can be used by film users, but it was designed with CCD imaging 
in mind.  Version 2.0 features include 
 

1. File support for most graphical images including TIFF, BMP, GIF, and JPG. 
2. You can filter you selection on what you view by telescope.  For example, view 

all the images taken with a refractor 
3. Enter detailed information about your CCD image 
4. Easy search options which include direct search, database listing, or a Windows 

Explorer Tree control.  (the Navigator) 
5. Includes an image viewer to view any image on your drive. 
6. View image properties of an image. 
7. You can view the image in Auto Fit mode, which shows the entire image or view 

full size. 
8. Open or Save As dialog shows a preview of the image before you open or save it. 
9. Save an image from one format to another. 
10. Some 50,000 US cities with location information 
11. Astronomy functions for sun, moon, and planets to get set/rise times, magnitudes, 

and much more. 
12. Printing 
13. Copy regions of an image to the clipboard or the entire image 
14. Version 2 has better zoom and moving the image around 

 
 
There is no online help with the program but this document should get you started and 
tell you how to use the program.  If you have questions or problems, there is e-mail 
support.  The program will work with Windows ME or higher, not sure about Windows 
98.  Send e-mail from www.galaxies.com. 
 
Version 2.0 is not backward compatible with version 1.0.  You will need to re-enter 
the images into version 2.0.  Sorry about that be there were just too many changes 
that made 2.0 much better. 
 

Program Installation 
 
Just double click on the msi file which is used by the Microsoft Windows Installer.  
Windows 98 users will have to download this program from the Microsoft web site. 
 
Just follow the instructions in the setup program.   You can change the destination path 
for the program to C:\CCD Explorer if you like.   The database is installed where the 
program is located.   It must stay in the same directory where the CCDExplorer,exe file is 
located.  You can have the images you add to the program anywhere. 
 
  
 
 



How to get started using CCD Explorer. 
 
CCD Explorer is set up to just start entering your images into the database.  However, by 
following theses setup steps to load information such as the instruments or CCD cameras 
you use, you will save time entering in new images into the database. 
 
1. Site Manager 
 
Under the File Menu, choose Site Manager.    By default, Tucson is the default favorite 
site.  Look for the city you are located or enter the latitude and longitude under the Site 
Information area.  Be sure to include a Site Name.   Next click Add Selected City to 
Favorite.  Once you have added the site, select the site and set the favorite as the default.  
Once you have done that you can delete Tucson. 
 
2. Instrument Setup 
 
Enter the current and past instruments you used.   You only need to setup the past 
instruments so that the telescope can be used in a filter.  Current instruments that are 
marked active will be listed when you add new images.   
 
Camera Setup 
 
Enter the current and past cameras you used.   This works just like the Instrument Setup 
worked except you are dealing with cameras. 
 
Object Setup 
 
Object setup has some defaults already which will work out for most users.  However, 
you can add additional ones as needed.   This is used to provide a drop down list when 
adding or updating images in the library. 
 
Program Defaults 
 
This is the last step you need before adding images to the database.  The Defined Filters 
is setup for most users.  You can add the additional ones you need.  This shows up when 
adding and updating images.  Other defaults can be set up for the most used instrument 
and camera.  Also, you can pick the default path for your images when you add or 
updated ones you put in the library.  I have my images in sub-directories by catalog under 
a main directory I called C:\CCD Explorer 
 
For setting up the items above or adding images, read on. 
 

 
 



Setting up equipment and program defaults 
 
Under the File Menu you have three options for setting up defaults for the program.   
Some of these are required to add new images to the database such as telescope and CCD 
setup.   
 
Site Manager 
The Site Manager is where you can look up latitude and longitude for most cities in the 
US.  It is also used to setup Favorite Sites used in the astronomy functions to get sunrise, 
sunset, moonrise, and much more.  You can also enter the latitude and longitude for a city 
not in the database 
 
Instrument Setup 
This information is used to fill the list box for what telescope was used to take the image.  
It shows up in the add image feature and the calculator.   It is also used for the calculator 
that comes with the program.  Under the File Menu, choose Instrument Setup.  If you 
have equipment setup, it will show in the list.  To add a new item, click New Row and 
enter the information.  If you click Active, the instrument will show up in the list when 
you add a new image.  All Instruments entered here will show up in the filter selection.   
The Instrument Name is what will show up in the list box when add images and when 
view information for the image.  The size (diameter of the telescope), F-Ratio, and Focal 
length of your equipment are also needed.  These items are used as defaults in the 
calculator.    
 
Camera Setup 
This information works the same way as the telescope setup so I won’t go into details.  
Click the Camera Setup under the File menu to run this option. 
 
Object Setup 
This feature under the File Menu allows you to enter the catalog and type of images you 
will enter.  There are predefined information here already but you can changed it as 
needed. 
 
Program Default Settings 
This section is used to enter the filter you use which show up as a list when you enter a 
new image.  Other defaults are used to default values when you enter a new item.  Image 
path is used as a default when selecting the image to add 
 



 
 
 



The Toolbar Options  
 
From left to right: 
 

1. This displays image properties including information you entered 
2. This icon will allow you to find an image.  F3 also will fire off this option 
3. Adds a new image to the database 
4. Edits the information for the current image 
5. Deletes the image from the database.  This does not delete the image file from the 

hard drive. 
6. Moves to the first image in the database.  If you have a filter on, it will move to 

the first image in the filter. 
7. Moves to the previous image in the database.  If you have a filter on, it will move 

to the previous image in the filter. 
8. Moves to the next image in the database.  If you have a filter on, it will move to 

the next image in the filter. 
9. Moves to the last image in the database.  If you have a filter on, it will move to 

the last image in the filter. 
10. Runs the Image Viewer 
11. Allows you to Print an image 
12. Opens the Scheduler 
13. Opens the Navigator with all of your images in a Windows Explorer format. 
14. Toggles  the Auto Fit feature to display the entire image or see it in full resolution 
15. Toggles Zoom Feature 
16. Allows you to select the tool to copy a region of the image 
17. Copies, Cut, and Paste a selected image. 
18. Set Filter will filter the Instrument and Camera  
19. Filter Off turns off the selected filter 

 
 
 
 



Adding an image to the database 
 
This feature allows you to add a new image to the database.   When you click the tool 
bar, the Update CCD Information dialog is displayed.  The full screen can be seen on the 
next page.   When this dialog is displayed, most of the information is fairly straight 
forward.  However, there are a few items I need to go over. 
 

1. The Sort Key is used to sort the database.  This is a required field and how you 
want to sort the items is up to you.  It is a text base input so it will sort by text.  
For example 01 comes before 20 but 10 will come before 2.   
This is what I do: 
    a) For Messier objects, I put M001 for M1 
    b) For NGC objects, I put NGC0023, so on for IC and other types 
    c) For Solar System objects, I put Z<date> where the date is in the format  
        yyyymmdd 

2. An image is required, object name, and sort key.  When you pick an image used 
the small button on the right near the bottom, you can select any image.  A 
preview will be displayed so you can see what you are picking. 

 

Updating information for an image 
 
This works the same way as the Add feature except that it displays the current 
information when the Update dialog is shown.   
 
 

Deleting an image from the Database 
 
This feature will remove an image from the database.    You will be asked if you want to 
remove the current image in view.  If you click on Yes, the image is removed from the 
database only.  You also have the option to delete the image from the computer. 
 



Add/ Update Image Screen 
 

 
 
 



Searching 
 
There are a few ways to see your images and find a certain object.   The toolbar has four 
icons that navigate you from one image to the next.    You can view the first, previous, 
next, or last image.  If you have a filter turned on, these icons will show you the first, 
previous, next, or last image in the filter.  There will be more on filters later.  
 
To find an image, you can click the Search Icon which is the second one from the left on 
the tool bar.    Just type in the object you are looking for and click OK.  The name of the 
object to find is what you entered in the Object text box when you added the image.  
If more than one item is found you will get a list.  If only one image is found, then the 
image will be loaded 
 
The database viewer is a menu under the Utilities menu..  When the viewer is 
displayed, you can sort on any column by clicking the column header.  To view the 
image, just double click on the row where the image information is located.   
 
The Navigator is another way to find an image in the database.  It is more graphical 
that the viewer which makes it easier to find an image.    When the navigator is displayed, 
it will load each of the categories and sub categories in a tree like structure.  The tree is 
based on the images you have stored in the system.  Just click on the + sign to open the 
tree branches until you see your objects listed.  To preview the object, just click one time 
on that item.  A preview image is displayed with some information.  To load the image 
and display it in the main program, double click on the item.    
 
 
 

The Image Viewer 
 
This feature allows you to view images that are not recorded in the data.  To load the 
image viewer, click the icon that looks like a tiny galaxy on the tool bar.  The Image 
Viewer is also found under the View Menu.  When you run this feature, the first thing that 
will happen is you will be asked to pick the image.  You do not have to pick an image 
now.    There is a help button that will tell you how to use the Image Viewer.   
 

Scheduler 
 
The scheduler feature of the program allows you to enter objects you wish to image.  To 
view the scheduler, click on the second icon from the right.   You can sort your items by 
clicking on the header of any column.  To add a new item, click the Add button and enter 
the information.  The scheduler is handy for planning your CCD image session.  I sort by 
constellation or season to see what I can image for a given time of the year. 
 



Tree Navigator 
 



 

Filters and Other Things 
 
Filters 
CCD Explorer has the support to view images taken with a certain telescope.  The 
instruments and cameras you enter in the setup will be displayed in the drop down list on 
the toolbar.  Select the instrument and camera you want to filter on and then click set 
Filter.  Using Set Filter Off removes the filter.  When the filter is on, only the images in 
the filter are seen. 
 
 
The CCD Calculator will compute the field of view for your CCD and the 
telescope you are using.  It also tells you the pixels per arc second  
 
The Auto Fit feature 
Under the View menu, you will find two items; full size and fit to screen.  The icon on 
the tool bar that has the letters AF toggles this feature off and on.  What Auto Fit does is 
show you the entire image in the view screen of the main program.  When Auto Fit is off, 
the full size image is displayed and scroll bars will be displayed if needed.   
 
Viewing Information on an Image   
The first icon on the tool bar from the left will toggle the CCD information window.  The 
information you entered when you added the image is displayed.  The information stays 
on until you turn it off 
 
Backing Up data 
The database that contains all the information you record is called CCD_Explorer.mdb.  
This is the only file you need to back up.  Your image files are not saved in the database, 
just the information and the directory path and filename of the image.    
 
 
Contact 
 
Support is my e-mail from my web site at www.galaxies.com 
 
 
 


